ERC-20 Services Degradation
Incident Report for Prime Trust
Resolved
Engineering has resolved the identified issue.
Posted May 29, 2021 - 12:38 PDT
Identified
Prime Trust has identified the cause of the issue and have implemented corrective actions.
Posted May 29, 2021 - 12:04 PDT
Investigating
Prime Trust is currently investigating an issue involving the posting of erc-20 transactions to the blockchain.
Posted May 29, 2021 - 10:09 PDT