Degraded system performance - Liquidity API
Incident Report for Prime Trust
Resolved
The Prime Trust Liquidity platform is fully operational. We have resolved any outstanding trades during the affected period. We will be resolving this incident.
Posted Nov 19, 2021 - 17:31 PST
Update
The Prime Trust Liquidity platform remains fully operational, and new trades are still being executed and settled. We are continuing to work on resolving prior outstanding trades from the period that our liquidity platform was experiencing degraded performance.
Posted Nov 18, 2021 - 11:06 PST
Update
The Prime Trust Liquidity platform is currently available and new trades can be executed and settled. We are working to resolve any prior outstanding trades that have not settled.
Posted Nov 17, 2021 - 10:03 PST
Update
This morning Prime Trust is experiencing degraded performance on our liquidity platform. Our Operations and Engineering teams are focused on resolving the issue.
Posted Nov 17, 2021 - 07:45 PST
Update
Prime Trust Liquidity remains up and trading is occurring. We will continue to monitor closely and will respond to any issues that arise.
Posted Nov 16, 2021 - 17:08 PST
Update
We have resumed trading on the Prime Core Liquidity platform. We will continue to monitor closely for any issues and will respond to them immediately.
Posted Nov 16, 2021 - 14:03 PST
Update
Liquidity Services remain paused while we continue to troubleshoot the issues. We will provide updates as they become available.
Posted Nov 16, 2021 - 11:57 PST
Update
We have temporarily paused our Liquidity services. We will continue to provide updates as they become available.
Posted Nov 16, 2021 - 09:51 PST
Update
We are still monitoring the situation. We will continue to provide updates as they become available.
Posted Nov 16, 2021 - 08:28 PST
Update
The volume of quotes is steadily decreasing, and we are still monitoring the situation. We will continue to provide updates as they become available.
Posted Nov 16, 2021 - 04:54 PST
Update
The volume of quotes is steadily decreasing, but we are still monitoring the situation. We will continue to provide updates as they become available.
Posted Nov 16, 2021 - 02:49 PST
Update
We have a volume of quotes that are in a state of "executed pending settlement", but due to a system issue we are currently unable to settle them. We expect to be able to settle these trades throughout the day Tuesday.
Posted Nov 16, 2021 - 00:16 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 15, 2021 - 23:53 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 15, 2021 - 21:49 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 15, 2021 - 21:23 PST
Update
We are continuing to investigate this issue.
Posted Nov 15, 2021 - 20:54 PST
Investigating
We are currently investigating this issue.
Posted Nov 15, 2021 - 20:23 PST
This incident affected: Prime Liquidity.